작성일자
카테고리 디자인툴/서브라임 텍스트

개발자들이 애용하는 서브라임 텍스트가 3 버전으로 업그레이드 됐는데 서브라임 텍스트가 인기가 있는 이유는 많은 플러그인을 쉽게 설치해 사용할 수 있다는데 있습니다. 그런데 서브라임 텍스트 3 버전에서는 2 버전에서처럼 패키지 설치를 하면 에러가 나더군요. 그래서 구글링 했더니 해결책이 나와있습니다. 역시 구글에는 모든 해결책이 있었습니다. 방법은 git을 이용해 설치하는 것입니다.



설치하는 장소를 알기 위해 메뉴에서 Preferences - Browse Packages를 선택하면 브라우저 창이 나타나는데 이곳이 설치할 장소입니다.



명령 프롬프트에서 위와같이 입력하고 엔터키를 누르면 경로가 바뀝니다. 경로는 이전 그림에서 주소창에서 필요한 부분만 복사해서 스페이스가 있는 Sublime Text 3 부분은 쌍따옴표를 넣어줘야합니다.


cd AppData\Roaming\"Sublime Text 3"\Packages


그런 다음 아래의 명령을 실행합니다.


git clone https://github.com/wbond/sublime_package_control.git "Package Control"


그러면 아래처럼 실행됩니다.



다시 아래의 명령을 실행해서 패키지 콘트롤 폴더로 들어갑니다.


cd "Package Control"


그런 다음, 다음의 명령을 실행합니다.


git checkout python3



그러면 위처럼 나타나고 이제 서브라임 텍스트에서 Ctrl+Shift+P 키를 누르면 패키지를 설치할 수 있는 창이 나타납니다.



ins를 치면 인스톨 패키지가 나타납니다. 엔터키를 치고 젠코딩을 할 수 있는 Emmet을 설치합니다.



에러가 날 경우 다시 설치하면 Emmet 문서가 나타납니다. 그런데 일부 플러그인은 서브라임 텍스트 3에서 자동으로 설치할 수 없고 아래처럼 설치하고 난 다음 실행을 하면 에러 메시지가 나타납니다. 축약형으로 된 CSS 파일을 정상으로 보기 위해 Prettifier를 설치하려고 했었죠. 



메시지 내용은 설치를 제거하고 수동으로 설치하라고 합니다. 우선 OK를 클릭하면 웹페이지가 나타납니다.



자동으로 설치한 플러그인은 같은 방법으로 제거합니다. Ctrl+Shift+P 키를 누르고 rem으로 검색해서 Remove Package를 선택한 다음 설치한 플러그인을 선택하면 제거됩니다.



이전 그림의 에러 메시지에서 OK를 클릭한 후 나온 웹페이지에서 위와같은 코드를 찾습니다. 줄의 처음부터 git까지만 드래그해서 복사합니다.



명령 프롬프트에서 Packages 폴더로 이동하기 위해 cd..을 입력 엔터키를 누릅니다. 그런다음 타이틀바를 우클릭하고 붙여넣기를 선택한 다음 엔터키를 누르면 아래처럼 설치됩니다.



실험을 해봐야겠죠.



위처럼 정리가 안된 스타일시트나 자바스크립트, HTML 파일을 불러와서 Pretify Code를 선택합니다. 그러면 아래처럼 예쁜(Pretty) 코드로 보이게 됩니다.



Prettifier와 반대의 역할을 하는 Minify도 수동으로 설치했더니 아래처럼 설치는 되지만 활성화가 되지 않습니다. 아직 서브라임 텍스트 3용으로 개발이 안된 모양입니다.




저작자 표시 비영리 변경 금지
신고
BlogIcon 시야

sublime text2 를 이용하는 도중 무슨 문제인지 설치한 패키지들이 동작하지 않아 해결방법을 모색하던중 검색을 통해 방문하게 되었습니다.

많은 도움 받고 갑니다. ^^

서브라임

관리자의 승인을 기다리고 있는 댓글입니다

나무

관리자의 승인을 기다리고 있는 댓글입니다

티스토리 툴바